Config files not uploading

0 like 0 dislike
19 views
I tried uploading my full configuration files to my OpenSolr index as a .zip file. It took about 15 minutes to complete, and when it did I received a JSON response telling me that the upload was successful, followed by a list of files that were updated. Upon then trying to get an edit those files in my OpenSolr control panel, it looked as though the file had not been uploaded at all, but instead was just showing the original default files that came with my new Solr index. After this, I tried to edit the schema.xml config file by copy-pasting it in from my local computer, and hit Finished Editing to save the changes. Upon opening the config file again, I noticed again that the changes did not take hold, but I was looking at the original default Solr schema.xml file. Is this a bug, or am I doing something wrong?

Thanks!
asked Sep 15 in Solr Config Files by Mark Labrecque

1 Answer

0 like 0 dislike
 
Best answer

Hey there

The fact that the system did not respond for 15 minutes, it might have been a temporary issue with one of the Opensolr servers, that is probably sorted out by now, or that there was something wrong with the archive you were trying to upload.
Also the Finish Editing button will close the editor. There is a separate button for Save File that reads "Save File" that will save the file :)

You should also take a look at the Automation REST APIs and try to upload your config files that way.
Ultimately, please check that your archive only contains text files->XML, txt (no binary files, .jar plugins, etc), and also, that your files are not too large. Also make sure all files are under the root directory and that there are no subdirectories in the archive.

If everything else fails, please email your:
- Opensolr Index name
- Registration email address
- Config files zip archive
to support@opensolr.com and we'll be happy to apply your config files for you.

Hope this helps.
 

answered Sep 15 by admin (3,620 points)
...